// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"0[1-9][0-9]{5}").unwrap();
let string = "0258714 0465666 1213655 568464668 225 75487 021523
56556 0236589 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}