const regex = /\b(?:W\.\s*Va\.|West\s+Virginia)\s*Code(?:\s+Ann\.?)?\s*§\s*\d+[A-Z]*-\d+[A-Z]*-\d+(?:\(\w+\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:W\\.\\s*Va\\.|West\\s+Virginia)\\s*Code(?:\\s+Ann\\.?)?\\s*§\\s*\\d+[A-Z]*-\\d+[A-Z]*-\\d+(?:\\(\\w+\\))?', 'gm')
const str = `W. Va. Code Ann. § 24A-2-5(a)
W.Va. Code § 15A-5-3
W.Va.Code § 22B-3-1
W. Va. Code § 15A-5-3
West Virginia Code Ann § 53-4A-7(a)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}