import re
regex = re.compile(r"\b(?:W\.\s*Va\.|West\s+Virginia)\s*Code(?:\s+Ann\.?)?\s*§\s*\d+[A-Z]*-\d+[A-Z]*-\d+(?:\(\w+\))?", flags=re.MULTILINE)
test_str = ("W. Va. Code Ann. § 24A-2-5(a)\n"
"W.Va. Code § 15A-5-3\n"
"W.Va.Code § 22B-3-1\n"
"W. Va. Code § 15A-5-3\n"
"West Virginia Code Ann § 53-4A-7(a)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")