// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:W\.\s*Va\.|West\s+Virginia)\s*Code(?:\s+Ann\.?)?\s*§\s*\d+[A-Z]*-\d+[A-Z]*-\d+(?:\(\w+\))?").unwrap();
let string = "W. Va. Code Ann. § 24A-2-5(a)
W.Va. Code § 15A-5-3
W.Va.Code § 22B-3-1
W. Va. Code § 15A-5-3
West Virginia Code Ann § 53-4A-7(a)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}