re = /\b(?:W\.\s*Va\.|West\s+Virginia)\s*Code(?:\s+Ann\.?)?\s*§\s*\d+[A-Z]*-\d+[A-Z]*-\d+(?:\(\w+\))?/m
str = 'W. Va. Code Ann. § 24A-2-5(a)
W.Va. Code § 15A-5-3
W.Va.Code § 22B-3-1
W. Va. Code § 15A-5-3
West Virginia Code Ann § 53-4A-7(a)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end