re = /\s*(input|output|inout)\s+(wire\s*|reg\s*)?\s*(\[(\d+):(\d+)\])?\s*(\w+)?/
str = 'x
input z
input [1:0] az
input wire [1:0] za
input wire [1:0]
y
z
output [12:0] a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end