package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:(?:"?((\w+)\b.*\b)"?)\s)?<?(([\w@]*)@(\w*)\.[a-zA-Z]{2,3})>?,?`)
var str = `peter@pan.com,
lucky <jack@pot.com>,
"William Tell" <billy@tell.com>,
"John Rambo, III" <johnny@rambo.com>,
"there, might, be, several, commas inside the quotes" <multiple@commas.com>,
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>`
var substitution = "{ fullName:'\1', firstWord:'\2', localPart:'\4', company:'\5', email:'\3'}"
fmt.Println(re.ReplaceAllString(str, substitution))
}