// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(?:(?:"?((\w+)\b.*\b)"?)\s)?<?(([\w@]*)@(\w*)\.[a-zA-Z]{2,3})>?,?"#).unwrap();
let string = "peter@pan.com,
lucky <jack@pot.com>,
\"William Tell\" <billy@tell.com>,
\"John Rambo, III\" <johnny@rambo.com>,
\"there, might, be, several, commas inside the quotes\" <multiple@commas.com>,
\"yes, this is also a valid email address, can you believe\" <yes@this@is@valid.com>";
let substitution = "{ fullName:'\\1', firstWord:'\\2', localPart:'\\4', company:'\\5', email:'\\3'}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}