import Foundation
let pattern = #"(?:(?:"?((\w+)\b.*\b)"?)\s)?<?(([\w@]*)@(\w*)\.[a-zA-Z]{2,3})>?,?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
peter@pan.com,
lucky <jack@pot.com>,
"William Tell" <billy@tell.com>,
"John Rambo, III" <johnny@rambo.com>,
"there, might, be, several, commas inside the quotes" <multiple@commas.com>,
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{ fullName:'\1', firstWord:'\2', localPart:'\4', company:'\5', email:'\3'}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)