using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^\w{2}-\d{5}-\d{3})(-\d+)";
string input = @"DS-71007-002-1
DN-80013-002-6
2""-VH-11008-MW01-03";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}