import re
regex = re.compile(r"(?<=^\w{2}-\d{5}-\d{3})(-\d+)", flags=re.MULTILINE)
test_str = ("DS-71007-002-1\n"
"DN-80013-002-6\n"
"2\"-VH-11008-MW01-03")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")