$re = '/(?<=^\w{2}-\d{5}-\d{3})(-\d+)/m';
$str = 'DS-71007-002-1
DN-80013-002-6
2"-VH-11008-MW01-03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);