const regex = /(?<=^\w{2}-\d{5}-\d{3})(-\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^\\w{2}-\\d{5}-\\d{3})(-\\d+)', 'gm')
const str = `DS-71007-002-1
DN-80013-002-6
2"-VH-11008-MW01-03`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}