import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[sife]+)(\\=.*)";
final String string = "MEDAISOUP_LISTEN_IP=123.123.123\n"
+ "Mohannad=1\n"
+ "sife=2";
final String subst = "MEDAISOUP_LISTEN_IP=1111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}