import Foundation
let pattern = #"(^[sife]+)(\=.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MEDAISOUP_LISTEN_IP=123.123.123
Mohannad=1
sife=2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"MEDAISOUP_LISTEN_IP=1111"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)