const regex = /(^[sife]+)(\=.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[sife]+)(\\=.*)', 'gm')
const str = `MEDAISOUP_LISTEN_IP=123.123.123
Mohannad=1
sife=2`;
const subst = `MEDAISOUP_LISTEN_IP=1111`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);