#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<!\d)\d{5}(?!\d))"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"im having trouble regarding my Regular Expression Pattern:" & @CRLF & _
"I need a pattern to extract exact 5 consecutive numeric only" & @CRLF & _
"ExampleA: 123456789 dsadss12345@3_- 1d22d333" & @CRLF & _
"ExampleB: 12345_ 2d2d2 aaa2222a" & @CRLF & _
"ExampleC: 2d2jj ddd_@12345" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")