import Foundation
let pattern = #"((?<!\d)\d{5}(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
im having trouble regarding my Regular Expression Pattern:
I need a pattern to extract exact 5 consecutive numeric only
ExampleA: 123456789 dsadss12345@3_- 1d22d333
ExampleB: 12345_ 2d2d2 aaa2222a
ExampleC: 2d2jj ddd_@12345
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)