$re = '/((?<!\d)\d{5}(?!\d))/m';
$str = '
im having trouble regarding my Regular Expression Pattern:
I need a pattern to extract exact 5 consecutive numeric only
ExampleA: 123456789 dsadss12345@3_- 1d22d333
ExampleB: 12345_ 2d2d2 aaa2222a
ExampleC: 2d2jj ddd_@12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);