#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:apple|banana|orange)(?:\s+(?:apple|banana|orange))*"
Local $sString = "sometext apple bananamoretext" & @CRLF & _
"sometext appledifferentmoretext" & @CRLF & _
"sometext bananaadditionaltext" & @CRLF & _
"sometext apple orangesomethingelse"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")