package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:apple|banana|orange)(?:\s+(?:apple|banana|orange))*`)
var str = `sometext apple bananamoretext
sometext appledifferentmoretext
sometext bananaadditionaltext
sometext apple orangesomethingelse`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}