$re = '/(?:apple|banana|orange)(?:\s+(?:apple|banana|orange))*/';
$str = 'sometext apple bananamoretext
sometext appledifferentmoretext
sometext bananaadditionaltext
sometext apple orangesomethingelse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);