using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:apple|banana|orange)(?:\s+(?:apple|banana|orange))*";
string input = @"sometext apple bananamoretext
sometext appledifferentmoretext
sometext bananaadditionaltext
sometext apple orangesomethingelse";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}