package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S\s$`)
var str = `this test can only have one line. Experiment with it ending in a space or an enter `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}