const regex = /\S\s$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S\\s$', '')
const str = `this test can only have one line. Experiment with it ending in a space or an enter `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}