$re = '/\S\s$/';
$str = 'this test can only have one line. Experiment with it ending in a space or an enter ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);