re = /\S\s$/
str = 'this test can only have one line. Experiment with it ending in a space or an enter '
# Print the match result
str.match(re) do |match|
puts match.to_s
end