using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d\.\d+";
string input = @"(LIST (LIST 'Abbott 'Ashley 'J ) '8697387888 'ajabbott@mail.university.edu 2.3073320999676614 )";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}