re = /\d\.\d+/
str = '(LIST (LIST \'Abbott \'Ashley \'J ) \'8697387888 \'ajabbott@mail.university.edu 2.3073320999676614 )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end