package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d\.\d+`)
var str = `(LIST (LIST 'Abbott 'Ashley 'J ) '8697387888 'ajabbott@mail.university.edu 2.3073320999676614 )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}