$re = '/\d\.\d+/';
$str = '(LIST (LIST \'Abbott \'Ashley \'J ) \'8697387888 \'ajabbott@mail.university.edu 2.3073320999676614 )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);