#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(^|[^\p{L}0-9_])corp\.([^\p{L}0-9_]|$)"
Local $sString = "SS Corp. Corp. LTd"
Local $sSubst = "$1Corporation$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)