re = /(?i)(^|[^\p{L}0-9_])corp\.([^\p{L}0-9_]|$)/
str = 'SS Corp. Corp. LTd'
subst = '$1Corporation$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result