package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^|[^\p{L}0-9_])corp\.([^\p{L}0-9_]|$)`)
var str = `SS Corp. Corp. LTd`
var substitution = "$1Corporation$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}