import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(^|[^\\p{L}0-9_])corp\\.([^\\p{L}0-9_]|$)";
final String string = "SS Corp. Corp. LTd";
final String subst = "$1Corporation$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}