import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.a..";
final String string = "# Match any(配對任何)\n\n"
+ "#下方為測試文字區塊\n"
+ "AE-403.jpg\n"
+ "BK-201.BMP\n"
+ "Qb-666.acg\n"
+ "AZ-404.qoo\n"
+ "ae-103.png\n"
+ "BK-201.svg\n"
+ "qb-666.ai\n"
+ "az-404.ai.tmp\n\n"
+ "#解釋:藍色部分就是透過規則/\\.a../所配對成功的文字,這裡是說幫我先配對 .(dot),再來配對 a,最後才是任何。\\. 代表使用這個特殊字元的原始用法\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}