import Foundation
let pattern = #"\.a.."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Match any(配對任何)
#下方為測試文字區塊
AE-403.jpg
BK-201.BMP
Qb-666.acg
AZ-404.qoo
ae-103.png
BK-201.svg
qb-666.ai
az-404.ai.tmp
#解釋:藍色部分就是透過規則/\.a../所配對成功的文字,這裡是說幫我先配對 .(dot),再來配對 a,最後才是任何。\. 代表使用這個特殊字元的原始用法
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)