# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.a.."
test_str = ("# Match any(配對任何)\n\n"
"#下方為測試文字區塊\n"
"AE-403.jpg\n"
"BK-201.BMP\n"
"Qb-666.acg\n"
"AZ-404.qoo\n"
"ae-103.png\n"
"BK-201.svg\n"
"qb-666.ai\n"
"az-404.ai.tmp\n\n"
"#解釋:藍色部分就是透過規則/\\.a../所配對成功的文字,這裡是說幫我先配對 .(dot),再來配對 a,最後才是任何。\\. 代表使用這個特殊字元的原始用法\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.