using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?";
string input = @"# Quantifier:?篇
#下方為測試文字區塊
http://www.kcg.gov.tw/Default.aspx
https://www.google.com.tw/
http://www.gov.taipei/
https://www.youtube.com/?gl=TW
https://www.netflix.com/tw/
#解釋:藍色部分就是透過規則/https?/所配對成功的文字,這裡判斷說http後,如果有 s 代表配對成功,沒有 s 也可以判斷成功。";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}