use strict;
my $str = '# Quantifier:?篇
#下方為測試文字區塊
http://www.kcg.gov.tw/Default.aspx
https://www.google.com.tw/
http://www.gov.taipei/
https://www.youtube.com/?gl=TW
https://www.netflix.com/tw/
#解釋:藍色部分就是透過規則/https?/所配對成功的文字,這裡判斷說http後,如果有 s 代表配對成功,沒有 s 也可以判斷成功。';
my $regex = qr/https?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}