// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?").unwrap();
let string = "# Quantifier:?篇
#下方為測試文字區塊
http://www.kcg.gov.tw/Default.aspx
https://www.google.com.tw/
http://www.gov.taipei/
https://www.youtube.com/?gl=TW
https://www.netflix.com/tw/
#解釋:藍色部分就是透過規則/https?/所配對成功的文字,這裡判斷說http後,如果有 s 代表配對成功,沒有 s 也可以判斷成功。";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}