import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "aria-label=\"Оценить\".*fill\\s?=\"(#\\d+)\"";
final String string = "<svg aria-label=\"Оценить\" class=\"jrei_5 \" fill =\"#262626\" height=\"24\" ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}