#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<protocol>couchbase(?:s)?)\:\/\/(?:(?<username>[^\:]+)\:(?<password>[^\@]{6,})@)?(?<host>[^\:]+(?:\:\d+)?)(?:\/(?<bucketName>[^\/\?]+))(?:(?:\/(?<scopeName>[^\/]+))(?:\/(?<collectionName>[^\/\?]+)))?(?:\/)?(?:\?(?<options>.*))?$"
Local $sString = "couchbases://usuario:password@localhost:1212/bucketName/" & @CRLF & _
"couchbases://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa" & @CRLF & _
"couchbases://usuario:password@localhost:1212/bucketName?opetion1=12&option2=kdjlasdfasdfa" & @CRLF & _
"couchbase://usuario:password@localhost:1212/bucketName/" & @CRLF & _
"couchbase://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa" & @CRLF & _
"couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews" & @CRLF & _
"couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews?opetion1=12&option2=kdjlasdfasdfa" & @CRLF & _
"couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews/?opetion1=12&option2=kdjlasdfasdfa" & @CRLF & _
"couchbase://usuario:password@localhost:1212/bucketName/scopeNews/?opetion1=12&option2=kdjlasdfasdfa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")