$re = '/^(?<protocol>couchbase(?:s)?)\:\/\/(?:(?<username>[^\:]+)\:(?<password>[^\@]{6,})@)?(?<host>[^\:]+(?:\:\d+)?)(?:\/(?<bucketName>[^\/\?]+))(?:(?:\/(?<scopeName>[^\/]+))(?:\/(?<collectionName>[^\/\?]+)))?(?:\/)?(?:\?(?<options>.*))?$/m';
$str = 'couchbases://usuario:password@localhost:1212/bucketName/
couchbases://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa
couchbases://usuario:password@localhost:1212/bucketName?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/
couchbase://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews/?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/?opetion1=12&option2=kdjlasdfasdfa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);