using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<protocol>couchbase(?:s)?)\:\/\/(?:(?<username>[^\:]+)\:(?<password>[^\@]{6,})@)?(?<host>[^\:]+(?:\:\d+)?)(?:\/(?<bucketName>[^\/\?]+))(?:(?:\/(?<scopeName>[^\/]+))(?:\/(?<collectionName>[^\/\?]+)))?(?:\/)?(?:\?(?<options>.*))?$";
string input = @"couchbases://usuario:password@localhost:1212/bucketName/
couchbases://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa
couchbases://usuario:password@localhost:1212/bucketName?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/
couchbase://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews/?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/?opetion1=12&option2=kdjlasdfasdfa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}