// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<protocol>couchbase(?:s)?)\:\/\/(?:(?<username>[^\:]+)\:(?<password>[^\@]{6,})@)?(?<host>[^\:]+(?:\:\d+)?)(?:\/(?<bucketName>[^\/\?]+))(?:(?:\/(?<scopeName>[^\/]+))(?:\/(?<collectionName>[^\/\?]+)))?(?:\/)?(?:\?(?<options>.*))?$").unwrap();
let string = "couchbases://usuario:password@localhost:1212/bucketName/
couchbases://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa
couchbases://usuario:password@localhost:1212/bucketName?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/
couchbase://usuario:password@localhost:1212/bucketName/?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/collectionNews/?opetion1=12&option2=kdjlasdfasdfa
couchbase://usuario:password@localhost:1212/bucketName/scopeNews/?opetion1=12&option2=kdjlasdfasdfa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}