using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(?=(\d\d\d)+\b)";
string substitution = @",";
string input = @"8574584847 + 87634587 + 7658";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}