use strict;
my $str = '8574584847 + 87634587 + 7658';
my $regex = qr/(?<=\d)(?=(\d\d\d)+\b)/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";