$re = '/(?<=\d)(?=(\d\d\d)+\b)/';
$str = '8574584847 + 87634587 + 7658';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;