re = /(?<=\d)(?=(\d\d\d)+\b)/
str = '8574584847 + 87634587 + 7658'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result